前回までに、vCenter ServerをNutanixクラスターの外に再配置しました。引き続き作業を行います。
2.バリデーションの確認
Convert Clusterを実行するためには、ほかにも設定を確認する必要がありますが、Convert Clusterには移行前のチェック機能がありますので、まずはこのチェック機能を実行してみたいと思います。
変換したいNutanixクラスターのPrism Elementを開き、「Settings」から「Convert Cluster」を開きます。
AVAILABLE HYPERVISORは「AHV」、VM BOOT OPTIONSは「Power off user VMs」を選択します。
「Validate」をクリックして、チェックを行います。
vCenter Serverの接続情報が表示されますので、NutanixのESXiホストを管理している、前回移動したvCenter Serverを指定します。
Validateには、それなりに時間がかかります。画面左上にタスクの状況が表示されますので、タスクから進捗を確認することも可能です。
しばらくすると結果が表示されます。
ここでは、ErrorとWarningの2つが表示されます。Errorはスキップすることができませんので、必ず設定変更を行う必要がある項目です。
Warningについてはスキップが可能ですが、注意事項を確認する必要があります。また、仮想マシンに関するWarningでは、NGTが未インストールの仮想マシンが検出されます。NGTが未インストールの仮想マシンについては、AHVへの変換後に仮想マシンのOSが起動しない可能性がありますので、慎重に確認してください。
この画面では、アドミッションコントロールの変更と、仮想スイッチに速度の異なるNICが混在している旨が表示されています。
スナップショットを保持している仮想マシンがある場合は、以下のようなエラーが表示されます。
3.vCenter Serverの設定変更
では、1つずつ設定を変更していきましょう。
アドミッションコントロールを無効化しますので、vSphere HAの設定を編集します。
ホストのフェイルオーバーキャパシティの定義基準を「無効」にします。
アップリンクNICの変更
本環境では、あえてNIC速度が混在する仮想スイッチを作成していました。この環境で不要なNICを、まずはアップリンクから外していきます。
速度の異なるNICや、スタンバイNICに設定されている不要なNICをすべて未使用アダプタに移動します。
再度Validateを実行すると、今度は違うエラーが出てきました。
1つは、HAの設定でPDLの設定を無効にする必要があります。
もう1つは、ポートグループがすべてのホストに存在していないために表示されているエラーです。仮想マシンが利用しているポートグループについて、標準スイッチを利用している場合は、すべてのホストに同じポートグループを追加します。
これで再び、Convert ClusterからValidateを実行してみます。
すると、Errorの項目が消え、仮想マシンのNGTインストールチェックだけがWarningとして表示されていることがわかります。
このままConvert Clusterを実行することもできますが、NGTが未インストールの状態ですと、AHVへの変換完了後に仮想マシンのゲストOSが起動しない可能性があるため、先にNGTをインストールしておく必要があります。
こちらは、次回紹介いたします。













0 件のコメント:
コメントを投稿